<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<meta name='viewport' content='width=device-width, initial-scale=1.0' />
<meta http-equiv='X-UA-Compatible' content='IE=edge' />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.nationalfootballpost.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://www.nationalfootballpost.com/wp-content/themes/bb-theme/js/html5shiv.js"></script>
	<script src="https://www.nationalfootballpost.com/wp-content/themes/bb-theme/js/respond.min.js"></script>
<![endif]-->
<title>Victim died in fight with Jenkins&#039; brother, authorities say - National Football Post</title>

<!-- This site is optimized with the Yoast SEO plugin v7.7 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.nationalfootballpost.com/victim-died-in-fight-with-jenkins-brother-authorities-say/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Victim died in fight with Jenkins&#039; brother, authorities say - National Football Post" />
<meta property="og:description" content="Victim died in fight with Jenkins&#8217; brother, authorities say The man whose body was found in New York Giants cornerback Janoris Jenkins&#8217; house on Tuesday died as the result of an altercation with Jenkins&#8217; brother, William Jackson, according to documents filed by authorities. In a police complaint and warrant against William Jackson, 34, the Bergen&hellip;" />
<meta property="og:url" content="https://www.nationalfootballpost.com/victim-died-in-fight-with-jenkins-brother-authorities-say/" />
<meta property="og:site_name" content="National Football Post" />
<meta property="article:publisher" content="http://facebook.com/nationalfootballpost" />
<meta property="article:tag" content="FLM" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2018-06-28T21:39:03+00:00" />
<meta property="article:modified_time" content="2018-06-28T21:39:04+00:00" />
<meta property="og:updated_time" content="2018-06-28T21:39:04+00:00" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/www.nationalfootballpost.com\/","sameAs":["http:\/\/facebook.com\/nationalfootballpost","https:\/\/twitter.com\/footballpost"],"@id":"https:\/\/www.nationalfootballpost.com\/#organization","name":"National Football Post","logo":"http:\/\/www.nationalfootballpost.com\/wp-content\/uploads\/2018\/05\/NFPlogo-400.png"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//www.nationalfootballpost.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="National Football Post &raquo; Feed" href="https://www.nationalfootballpost.com/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.nationalfootballpost.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='otw_sbm.css-css'  href='https://www.nationalfootballpost.com/wp-content/plugins/sidebar-manager-light/css/otw_sbm.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='sab-font-css'  href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,700,400italic,700italic&#038;subset=latin' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=2.1.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='sab-plugin-css'  href='https://www.nationalfootballpost.com/wp-content/plugins/simple-author-box/assets/css/simple-author-box.min.css?ver=2.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='ce_responsive-css'  href='https://www.nationalfootballpost.com/wp-content/plugins/simple-embed-code/css/video-container.min.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-data-tables-css'  href='https://www.nationalfootballpost.com/wp-content/plugins/posts-table-pro/assets/css/datatables/datatables.min.css?ver=1.10.16' type='text/css' media='all' />
<link rel='stylesheet' id='posts-table-pro-css'  href='https://www.nationalfootballpost.com/wp-content/plugins/posts-table-pro/assets/css/posts-table-pro.min.css?ver=2.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://www.nationalfootballpost.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.9' type='text/css' media='all' />
<link rel='stylesheet' id='fl-builder-google-fonts-a0dc0f37a2c19d739b7445c77d065820-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C700%7CRoboto+Condensed%3A700%7COpen+Sans+Condensed%3A700&#038;ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='mono-social-icons-css'  href='https://www.nationalfootballpost.com/wp-content/themes/bb-theme/css/mono-social-icons.css?ver=1.6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-magnificpopup-css'  href='https://www.nationalfootballpost.com/wp-content/plugins/bb-plugin/css/jquery.magnificpopup.css?ver=2.1.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://www.nationalfootballpost.com/wp-content/themes/bb-theme/css/bootstrap.min.css?ver=1.6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='fl-automator-skin-css'  href='https://www.nationalfootballpost.com/wp-content/uploads/bb-theme/skin-5b3169585d56b.css?ver=1.6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='fl-child-theme-css'  href='https://www.nationalfootballpost.com/wp-content/themes/bb-theme-child/style.css?ver=4.9.6' type='text/css' media='all' />
<script type='text/javascript' src='https://www.nationalfootballpost.com/wp-content/plugins/wp-d3/js/d3.v35.min.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.nationalfootballpost.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.nationalfootballpost.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.nationalfootballpost.com/wp-content/themes/bb-theme-child/js/custom.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://www.nationalfootballpost.com/wp-content/themes/bb-theme-child/js/infinite-scroll.min.js?ver=4.9.6'></script>
<link rel='https://api.w.org/' href='https://www.nationalfootballpost.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nationalfootballpost.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nationalfootballpost.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.6" />
<link rel='shortlink' href='https://nfp.news/tm7' />
<link rel="alternate" type="application/json+oembed" href="https://www.nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nationalfootballpost.com%2Fvictim-died-in-fight-with-jenkins-brother-authorities-say%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nationalfootballpost.com%2Fvictim-died-in-fight-with-jenkins-brother-authorities-say%2F&#038;format=xml" />
<meta name="generator" content="Feed to Post 3.7.5" />
<link rel="canonical" href="https://www.nationalfootballpost.com/newsml/fieldlevelmedia_str_20180629T000448_0800_000012874_2.xml" /><style type="text/css">.saboxplugin-wrap .saboxplugin-gravatar img {-webkit-border-radius:50%;-moz-border-radius:50%;-ms-border-radius:50%;-o-border-radius:50%;border-radius:50%;}.saboxplugin-wrap .saboxplugin-authorname a {color:#212121;}.saboxplugin-wrap .saboxplugin-authorname {font-family:"Roboto Condensed";}.saboxplugin-wrap .saboxplugin-desc {font-family:Roboto Condensed;}.saboxplugin-wrap .saboxplugin-desc {font-style:italic;}.saboxplugin-wrap {margin-top:20px; margin-bottom:10px; padding: 5px 5px }.saboxplugin-wrap .saboxplugin-authorname {font-size:20px; line-height:27px;}.saboxplugin-wrap .saboxplugin-desc p, .saboxplugin-wrap .saboxplugin-desc {font-size:16px !important; line-height:23px !important;}.saboxplugin-wrap .saboxplugin-web {font-size:14px;}.saboxplugin-wrap .saboxplugin-socials .saboxplugin-icon-color.fa:before {font-size:18px;}.saboxplugin-wrap .saboxplugin-socials .saboxplugin-icon-color.fa {width:36px; height:36px; line-height:36px; }</style><link rel="icon" href="https://www.nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://www.nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-270x270.jpg" />
		<style type="text/css" id="wp-custom-css">
			.fl-post-cats-tags{
		    padding: 0px 0px 0px 0px;	
				border-bottom:4px solid #e6e6e6
}

.share-social{
	border-bottom:4px solid #e6e6e6
}


.container
{max-width: 93%}


.fl-sidebar-left
{
	padding-right: 2%;
	padding-left: 0px;
}

.fl-post-cats-tags a, .share-social a {
    text-transform: uppercase;
    color: #000;
		font-size: 18px;
		font-weight: 600;
    font-style: normal;
		
}
.fl-archive .fl-post
{
	border-bottom: 0px;
}


div.share-social {
    letter-spacing: 7px;
    float: right;
	padding-top: 10px;
}

li a{
	font-size: 16px;
  color: #555;
	font-style: normal;
  display: block;
	padding-bottom: 4px;
	font-weight: 600;
	text-transform: uppercase;	
}

li{
	font-size: 14px;
  color: #7b7b7b;
	font-style: italic;
	font-weight: 500;
	text-transform: uppercase;	
	padding-bottom: 6px;
	border-bottom: 2px solid #e6e6e6
	
}

.fl-widget-title {
	border-style: solid;
  border-width: 4px 0px 4px 0px; 
	text-align: center;
	padding: 5px
	
}


.fl-post-title{
     margin-bottom: 0px;}

.fl-post-author {
	text-transform: uppercase;
	font-style: italic;
	font-weight:600;
	font-size: 18px;
}
.tooltip-inner{letter-spacing: 1px;}
.fl-post-meta-bottom {
    border-top: none;
    font-style: italic;
    margin-top: 0;
    padding-top: 10px;
    float: left;
}
.btn-primary{
	    border: none !important;
    background: 0 0 !important;;
    color: #000 !important;;
    box-shadow: none !important;;
    padding: 0 !important;;
    margin-bottom: 5px !important;;
}		</style>
	<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-5166086-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-5166086-1');
</script>

</head>

<body class="post-template-default single single-post postid-81550 single-format-standard fl-preset-default fl-fixed-width fl-scroll-to-top fl-search-active" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="fl-page">
	<header class="fl-page-header fl-page-header-fixed fl-page-nav-right fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile">
	<div class="fl-page-header-wrap">
		<div class="fl-page-header-container container">
			<div class="fl-page-header-row row">
				<div class="fl-page-logo-wrap col-md-3 col-sm-12">
					<div class="fl-page-header-logo">
						<a href="https://www.nationalfootballpost.com/"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://www.nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post" /><meta itemprop="name" content="National Football Post" /></a>
					</div>
				</div>
				<div class="fl-page-fixed-nav-wrap col-md-9 col-sm-12">
					<div class="fl-page-nav-wrap">
						<nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu">
							<button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse">
								<span><i class="fa fa-bars"></i></span>
							</button>
							<div class="fl-page-nav-collapse collapse navbar-collapse">
								<ul id="menu-top-nav" class="nav navbar-nav navbar-right menu"><li id="menu-item-78448" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-78448"><a href="https://www.nationalfootballpost.com/category/news/">News</a></li>
<li id="menu-item-80343" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a>
<ul class="sub-menu">
	<li id="menu-item-80747" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80747"><a href="https://www.nationalfootballpost.com/category/columns/draft/">Draft</a></li>
	<li id="menu-item-80344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://www.nationalfootballpost.com/category/columns/esports/">Esports</a></li>
	<li id="menu-item-80345" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80345"><a href="https://www.nationalfootballpost.com/category/columns/off-the-charts/">Off the Charts</a></li>
	<li id="menu-item-80748" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80748"><a href="https://www.nationalfootballpost.com/category/columns/off-the-field/">Off the Field</a></li>
</ul>
</li>
<li id="menu-item-78387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78387"><a href="https://www.nationalfootballpost.com/category/columns/betting/">Betting</a></li>
<li id="menu-item-78499" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">More</a>
<ul class="sub-menu">
	<li id="menu-item-78502" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://www.nationalfootballpost.com/contact-nfp/">Contact NFP</a></li>
	<li id="menu-item-78500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78500"><a href="https://www.nationalfootballpost.com/privacy/">Privacy</a></li>
	<li id="menu-item-80079" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://www.nationalfootballpost.com/terms/">Terms</a></li>
</ul>
</li>
<li id="menu-item-78452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://www.nationalfootballpost.com/archive/">Archive</a></li>
</ul>							</div>
						</nav>
					</div>
				</div>
			</div>
		</div>
	</div>
</header><!-- .fl-page-header-fixed -->
<header class="fl-page-header fl-page-header-primary fl-page-nav-centered fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
	<div class="fl-page-header-wrap">
		<div class="fl-page-header-container container">
			<div class="fl-page-header-row row">
				<div class="col-md-12 fl-page-header-logo-col">
					<div class="fl-page-header-logo" itemscope="itemscope" itemtype="https://schema.org/Organization">
						<a href="https://www.nationalfootballpost.com/" itemprop="url"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://www.nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post" /><meta itemprop="name" content="National Football Post" /></a>
					</div>
				</div>
			</div>
		</div>
	</div>
	<div class="fl-page-nav-wrap">
		<div class="fl-page-nav-container container">
			<nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
				<button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse">
					<span><i class="fa fa-bars"></i></span>
				</button>
				<div class="fl-page-nav-collapse collapse navbar-collapse">
					<ul id="menu-top-nav-1" class="nav navbar-nav menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-78448"><a href="https://www.nationalfootballpost.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80747"><a href="https://www.nationalfootballpost.com/category/columns/draft/">Draft</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://www.nationalfootballpost.com/category/columns/esports/">Esports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80345"><a href="https://www.nationalfootballpost.com/category/columns/off-the-charts/">Off the Charts</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80748"><a href="https://www.nationalfootballpost.com/category/columns/off-the-field/">Off the Field</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78387"><a href="https://www.nationalfootballpost.com/category/columns/betting/">Betting</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">More</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://www.nationalfootballpost.com/contact-nfp/">Contact NFP</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78500"><a href="https://www.nationalfootballpost.com/privacy/">Privacy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://www.nationalfootballpost.com/terms/">Terms</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://www.nationalfootballpost.com/archive/">Archive</a></li>
</ul><div class="fl-page-nav-search">
	<a href="javascript:void(0);" class="fa fa-search"></a>
	<form method="get" role="search" action="https://www.nationalfootballpost.com/" title="Type and press Enter to search.">
		<input type="search" class="fl-search-input form-control" name="s" placeholder="Search" value="" />
	</form>
</div>
				</div>
			</nav>
		</div>
	</div>
</header><!-- .fl-page-header -->
	<div class="fl-page-content" itemprop="mainContentOfPage">

		
<div class="container">
	<div class="row">
		
		<div class="fl-sidebar fl-sidebar-left fl-sidebar-display-desktop col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
		<aside id="custom_html-4" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">FEATURED</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://www.nationalfootballpost.com/all-the-nfl-suspensions-for-2018-in-one-place/" title="All the NFL Suspensions for 2018 in One Place">All the NFL Suspensions for 2018 in One Place</a> 10 hours ago </li><li ><a href="https://www.nationalfootballpost.com/2019-nfl-draft-preview-r/" title="2019 NFL Draft Preview &#8211; RBs">2019 NFL Draft Preview &#8211; RBs</a> 12 hours ago </li><li ><a href="https://www.nationalfootballpost.com/success-before-and-after-a-super-bowl-win/" title="Success Before and After a Super Bowl Win">Success Before and After a Super Bowl Win</a> 1 day ago </li><li ><a href="https://www.nationalfootballpost.com/the-intersection-of-the-nfl-and-esports-afc-west/" title="The Intersection of the NFL and Esports: AFC West">The Intersection of the NFL and Esports: AFC West</a> 2 days ago </li><li ><a href="https://www.nationalfootballpost.com/2019-nfl-draft-preview-tes/" title="2019 NFL Draft Preview &#8211; TEs">2019 NFL Draft Preview &#8211; TEs</a> 3 days ago </li></ul></div></aside><aside id="custom_html-3" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">RECENT</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://www.nationalfootballpost.com/all-the-nfl-suspensions-for-2018-in-one-place/" title="All the NFL Suspensions for 2018 in One Place">All the NFL Suspensions for 2018 in One Place</a> 10 hours ago </li><li ><a href="https://www.nationalfootballpost.com/2019-nfl-draft-preview-r/" title="2019 NFL Draft Preview &#8211; RBs">2019 NFL Draft Preview &#8211; RBs</a> 12 hours ago </li><li ><a href="https://www.nationalfootballpost.com/success-before-and-after-a-super-bowl-win/" title="Success Before and After a Super Bowl Win">Success Before and After a Super Bowl Win</a> 1 day ago </li><li ><a href="https://www.nationalfootballpost.com/nfl-notebook-victim-died-in-fight-with-jenkins-brother-authorities-say/" title="NFL notebook: Victim died in fight with Jenkins&#8217; brother, authorities say">NFL notebook: Victim died in fight with Jenkins&#8217; brother, authorities say</a> 1 hour ago </li><li class="current"><a href="https://www.nationalfootballpost.com/victim-died-in-fight-with-jenkins-brother-authorities-say/" title="Victim died in fight with Jenkins&#8217; brother, authorities say">Victim died in fight with Jenkins&#8217; brother, authorities say</a> 1 hour ago </li><li ><a href="https://www.nationalfootballpost.com/bucs-qb-winston-receives-3-game-suspension/" title="Bucs QB Winston receives 3-game suspension">Bucs QB Winston receives 3-game suspension</a> 7 hours ago </li><li ><a href="https://www.nationalfootballpost.com/panthers-owner-richardson-fined-2-75-million-for-inappropriate-workplace-conduct/" title="Panthers owner Richardson fined $2.75 million for inappropriate workplace conduct">Panthers owner Richardson fined $2.75 million for inappropriate workplace conduct</a> 8 hours ago </li><li ><a href="https://www.nationalfootballpost.com/hammerin-hank-goldberg-shares-stories-of-legendary-jimmy-the-greek/" title="Hammerin’ Hank Goldberg Shares Stories of Legendary Jimmy the Greek">Hammerin’ Hank Goldberg Shares Stories of Legendary Jimmy the Greek</a> 12 hours ago </li></ul></div></aside>	</div>
		
		<div class="fl-content fl-content-right col-md-9">
							<article class="fl-post post-81550 post type-post status-publish format-standard hentry category-news tag-flm" id="fl-post-81550" itemscope itemtype="https://schema.org/BlogPosting">

	
	<header class="fl-post-header">
		<h1 class="fl-post-title" itemprop="headline">
			Victim died in fight with Jenkins&#8217; brother, authorities say					</h1>
		<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://www.nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://www.nationalfootballpost.com/victim-died-in-fight-with-jenkins-brother-authorities-say/" /><meta itemprop="datePublished" content="1 hour ago" /><meta itemprop="dateModified" content="1 hour ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://www.nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://www.nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>	</header><!-- .fl-post-header -->

	
	
	<div class="fl-post-content clearfix" itemprop="text">
		<h2><title>Victim died in fight with Jenkins&#8217; brother, authorities say</title></h2><p></p><p>
The man whose body was found in New York Giants cornerback Janoris Jenkins&#8217; house on Tuesday died as the result of an altercation with Jenkins&#8217; brother, William Jackson, according to documents filed by authorities.
</p>
</p><p>
In a police complaint and warrant against William Jackson, 34, the Bergen County prosecutor&#8217;s office said Jackson and Roosevelt Rene, a 25-year-old Jenkins family friend and music producer, had a &#8220;physical altercation&#8221; Monday night in Janoris Jenkins&#8217; Fair Lawn, N.J., home, resulting in Rene&#8217;s death.
</p>
</p><p>
William Jackson was arrested in Canandaigua, N.Y., and charged with aggravated manslaughter on Wednesday, one day after Rene&#8217;s body was found in the basement of the home. Multiple reports have said both men had been living in the house.
</p>
</p><p>
According to the complaint, Jackson showed extreme indifference to human life and recklessly caused Rene&#8217;s death before fleeing to upstate New York, where his arrest occurred for a separate matter &#8212; a parole violation. The complaint adds that investigators learned of the fight while interviewing Jenkins in the Ontario County Jail.
</p>
</p><p>
The complaint does not specify any injuries Rene suffered from the fight, or a cause of death. NFL Network reported on Tuesday that police were investigating a possible strangulation/suffocation as the cause of death.
</p>
</p><p>
Jenkins remains in custody in New York and does not yet have a court appearance scheduled.
</p>
</p><p>
According to public records, Jenkins was on parole for a pair of felony drug convictions in New York.
</p>
</p><p>
Multiple reports have said Janoris Jenkins is not in New Jersey and has been staying in Florida &#8212; where he lives during the offseason &#8212; since the Giants broke from their offseason practices, which ended June 14.
</p>
</p><p>
The 29-year-old is entering his third year with the Giants. The Pahokee, Fla., native played for Florida in college before finishing his career at North Alabama.
</p>
</p><p>
A Giants spokesperson confirmed the team is &#8220;aware of and monitoring the situation.&#8221;
</p>
</p><p>
&#8211;Field Level Media</p>
	</div><!-- .fl-post-content -->

	    <div class="post-bot">
	    <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://www.nationalfootballpost.com/category/news/" rel="category tag">News</a></div></div>        <div class="share-social">
    <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fwww.nationalfootballpost.com%2Fvictim-died-in-fight-with-jenkins-brother-authorities-say%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
    <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Victim died in fight with Jenkins’ brother, authorities say+http://nfp.news/tm7" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
    <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Victim died in fight with Jenkins&#8217; brother, authorities say&#32;&#32;http://nfp.news/tm7" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
    <button class="btn btn-primary" data-clipboard-text="http://nfp.news/tm7"><i class="fa fa-link" aria-hidden="true"></i></button>
        </div>
    </div>
		
</article>


<!-- .fl-post -->
					</div>
		
				
	</div>
</div>


	</div><!-- .fl-page-content -->
		</div><!-- .fl-page -->
<a href="#" id="fl-to-top"><i class="fa fa-chevron-up"></i></a><script type='text/javascript' src='https://www.nationalfootballpost.com/wp-content/plugins/posts-table-pro/assets/js/datatables/datatables.min.js?ver=1.10.16'></script>
<script type='text/javascript' src='https://www.nationalfootballpost.com/wp-content/plugins/posts-table-pro/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var posts_table_params = {"ajax_url":"https:\/\/www.nationalfootballpost.com\/wp-admin\/admin-ajax.php","ajax_nonce":"6e0c777513","wrapper_class":"posts-table-wrapper bb-theme","language":{"info":"Showing _START_ to _END_ of _TOTAL_ entries","infoEmpty":"Showing 0 entries","infoFiltered":"(_MAX_ entries in total)","lengthMenu":"Show _MENU_ entries","emptyTable":"No data available in table.","zeroRecords":"No matching records found.","search":"Search:","paginate":{"first":"First","last":"Last","next":"Next","previous":"Previous"},"thousands":",","decimal":".","aria":{"sortAscending":": activate to sort column ascending","sortDescending":": activate to sort column descending"},"filterBy":"Filter:","resetButton":"Reset"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.nationalfootballpost.com/wp-content/plugins/posts-table-pro/assets/js/posts-table-pro.min.js?ver=2.0.3'></script>
<script type='text/javascript' src='https://www.nationalfootballpost.com/wp-content/themes/bb-theme/js/jquery.throttle.min.js?ver=1.6.5.1'></script>
<script type='text/javascript' src='https://www.nationalfootballpost.com/wp-content/plugins/bb-plugin/js/jquery.magnificpopup.min.js?ver=2.1.2.4'></script>
<script type='text/javascript' src='https://www.nationalfootballpost.com/wp-content/plugins/bb-plugin/js/jquery.fitvids.min.js?ver=1.2'></script>
<script type='text/javascript' src='https://www.nationalfootballpost.com/wp-content/themes/bb-theme/js/bootstrap.min.js?ver=1.6.5.1'></script>
<script type='text/javascript' src='https://www.nationalfootballpost.com/wp-content/themes/bb-theme/js/theme.min.js?ver=1.6.5.1'></script>
<script type='text/javascript' src='https://www.nationalfootballpost.com/wp-includes/js/wp-embed.min.js?ver=4.9.6'></script>
</body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/


Served from: nationalfootballpost.com @ 2018-06-28 22:49:39 by W3 Total Cache
-->